Keeping your world up and running.®

Fluke ScopeMeter® 190C Series Firmware Upgrade

Please contact the Fluke service department for firmware updates on this product.
For Version V7.0x, V8.00 or V8.02

A firmware upgrade for ScopeMeter test tool 190C/2x5 Series is available, major changes are:

  • Several issues on CAN, FF and Profibus DP have been resolved (2x5C only)
  • F2 is disabled in eye-pattern button bar when bus health is off (2x5C only)
  • Fixed dot-join status after leaving bushealth mode (2x5C only)
  • Fixed trigger status indication after leaving bushealth mode (2x5C only)
  • No data banner no longer appears when wiring diagram is shown (2x5C only)
  • Fixed recall function, not correctly recalling screen + data (V8.04)
  • Fixed TrendPlot Save. UI only showed screen + setting not recording (V8.04)
  • Fixed Trend storage (V8.02)
  • Remote control Fluke 190 Series improved (V7.06)
  • Zoom in 2s/div timebase setting improved and micro symbol added in readings symbol table (V7.04)
  • Improved screen update rate (V7.02)
  • Deeper waveform memory up to 3K spectrum analysis using Fast Fourier Transformation (V7.00)
  • Two new trigger modes (n-cycle and dual edge) (V7.00)
  • Cursor limited automatic measurement (rms Watt etc. between cursors) (V7.00)

Upgrading Version V7.0x, V8.00 or V8.02 to Version V8.04 - Instruments with version V7.01 to V8.02 are field upgradable free of charge. Please contact the Fluke service department for firmware updates on this product.

FlashTool Software Requirements:

  • Fluke 190C/2x5C Series Color ScopeMeter, with firmware V7.0 1V 8.0 2. (See firmware level check below).
  • A PC running Windows XP or Vista, with a free RS-232 or USB port to perform the software installation.
  • PM9080 or OC4USB (RevII) optically isolated serial interface cable (as included with the ScopeMeter 19xC/S model and with the SCC-190 kit) for data interconnection between the PC and the instrument.

Upgrading Earlier Versions - Instruments with firmware version V5.0x and V6.x cannot be upgraded to V8.04 in the field. These instruments require re-calibration after upgrading. Therefore these units must be returned to a Fluke Authorized Service Center. Contact your local service center and order a firmware upgrade and calibration according to PCN 4841. Note: For the firmware upgrade and calibration a nominal fee will be charged.

Firmware Level Check - Press USER and F3 [VERSION & CAL …] on your ScopeMeter to check its firmware version.


Please contact the Fluke service department for firmware updates on this product.
For versions V6.14, V6.13, V6.12, V6.11, V6.10, V6.00, V5.04, V5.03 (Note: an upgrade to V7.06 requires re-calibration, contact Fluke service center)